Pages

Thursday, July 18, 2013

Installing Office Web Apps 2013 for SharePoint 2013

This blog is part of Series : Comprehensive SharePoint 2013 Development Environment Installation and Configuration

Overview

This blog article discusses how to install Office Web Apps 2013 on a dedicated server and then integrate with an existing SharePoint 2013 Farm.

Assuming you had already established a SharePoint 2013 Farm and have instantiated a Windows 2012 Server instance dedicated for installing Office Web Apps 2013 Server based on earlier blog.

Reference http://technet.microsoft.com/en-us/library/jj219455.aspx

Steps

Office Web App Server Pre Requisites Installation On Windows 2012

Login to OWA2013 server as SPSetup and run the PowerShell command as administrator.

clip_image001

clip_image001[1]

Run below command script to install and pre-requisites.

Add-WindowsFeature Web-Server,Web-Mgmt-Tools,Web-Mgmt-Console,Web-WebServer,Web-Common-Http,Web-Default-Doc,Web-Static-Content,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Security,Web-Filtering,Web-Windows-Auth,Web-App-Dev,Web-Net-Ext45,Web-Asp-Net45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Includes,InkandHandwritingServices



clip_image002



clip_image003



Restart the server



Office Web App Server Installation



Mount Office Web Apps 2013 Install on the OWA2013 server and run the Install



clip_image004



clip_image005



Office Web App Server CU Installation



Download and install the Office Web Apps Server 2013 update KB2810007.



From <http://technet.microsoft.com/en-us/library/jj219455.aspx>



clip_image006



clip_image007



Office Web App Server Configuration



Step 1: Create OWA Farm and Configure to use HTTP and Support Editing



Reference http://technet.microsoft.com/en-us/library/jj219455.aspx



Login on to OWA2013 Server with SPSetup Account



From an elevated PowerShell command prompt run below command



clip_image008



clip_image009



Test by accessing from outside your server http://owa2013/hosting/discovery



clip_image010



Office Web App Server Configuration on OWA2013 Server



Step 2: Configure SharePoint 2013 Farm to use the OWA Server



Reference



Login to SP2013WFE with SPSetup



From an elevated PowerShell command prompt run below command



clip_image011



Now you should see a long list application extension registration with the WOPIZone



To confirm type and test below command to verify that the new zone is internal-http



clip_image012



Change the AllowOAuthOverHttp setting in SharePoint 2013 to True. Run below command



clip_image013



That means we will need to allow SharePoint to allow OAuth over HTTP by running below commands



clip_image014



Now check one more time the status of OAuth over http



clip_image015



Now once again check the WOPI Zone and as you can see it is still se to internal-https



For this installation test since I had used internal and http, I am going to set the WOPI Zone accordingly as below.



clip_image016



Test Office Web Apps with SP 2013



Browse to SharePoint site as user and not as system account (OWA does not work for system account)



clip_image017



clip_image018



clip_image019



clip_image020



Load sample Word Document



clip_image021





Click to open the document in OWA mode.

7 comments:

Joey said...

I exactly did install in the same way.. but I got "Unhealthy" state. What did I miss?? Where should I check??

Rajesh Agadi said...

Joey,

Where did you get this "Unhealthy" state message? Please elaborate.

Thanks
Rajesh

Anonymous said...

Joey
Have a look to your Windows firewall (TCP 809 must be reachable).

James Key said...

I completed all the above steps which worked perfectly from the actual servers, but externally I get "Internet Explorer Cannot display this webpage." messages. Is there a different set of steps to make it where you can access it from off the servers? Like from any computer off the internet?

Rajesh Agadi said...

James Key,

What URL address did you try when you got the error message in IE?

-Rajesh

Somashekar G Achar said...

I have installed the Office web APPS Server in exact steps i didnt get any error installed successfully but i couldnt find word viewing service and powerpoint service

Rhygar said...

I got "Unhealthy" too. I got that status in OWA Server, when type: Get-OfficeWebAppsMachine